More Adobe Installer disappointments

Adobe CS5By now it’s fairly well-known that the current installer for the Adobe CS5 products has a serious shortcoming: it fails when no-one is logged in. As this normally an ideal state in which to deploy software in enterprise environments (no-one is logged in, so you don’t have to worry about interfering with a user’s work, or worry that users will attempt to use applications that are being installed/updated/removed), this is a big problem. Adobe plans to address this in the future.

I thought I’d check to see if a similar issue affects the AdobePatchInstaller.app that is part of the Adobe CS5 updaters.

At least for the Adobe Bridge CS5 4.0.2 update, it fails when no-one is logged in, but for different reasons that the failure of a CS5 product install. Here’s the end of the log of a failed session:


-------------------------------------- Summary --------------------------------------
- 1 fatal error(s), 3 error(s), 1 warning(s)
WARNING: Display requirements not met for {2C8FBE83-2D3E-4CE6-A912-4BED85BCAC06}
ERROR: Unable to locate folder for token UserInternetPlugins.
ERROR: The following payload errors were found during install:
ERROR: - Adobe Bridge CS5_4.0.2_AdobeBridge4-mul: Install failed
FATAL ERROR: Database file 'Install.db' does not exist.

Search the same string above to find when the error occured.
-------------------------------------------------------------------------------------
Exit Code: 7 - Unable to complete Silent workflow
*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
END - Installer Session
*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

This looks to me like it’s failing because it’s looking for the InternetPlugins folder for the current user, and since there _is_ no current user, it aborts.

If I log in to the GUI and try again, it succeeds:


-------------------------------------- Summary --------------------------------------
- 0 fatal error(s), 0 error(s), 0 warning(s)
-------------------------------------------------------------------------------------
Exit Code: 0 - No error
*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
END - Installer Session
*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

It’s beyond exasperating.

More Adobe Installer disappointments

2 thoughts on “More Adobe Installer disappointments

  1. So, what’s more, if you log into a machine as the admin user and install this, the internet plugins for the other users on the machine won’t get updated.

    What bollocks.

Comments are closed.